IPv6 Multiprotocol BGP (MP BGP) Overview and Configuration

Multiprotocol BGP (MP-BGP) is a BGP extension that enables BGP (Border Gateway Protocol) to transport routing information for different network layers and address families. It can carry Network Layer Reachability Information (NLRI) for IPv4, IPv6, and Multiprotocol Label Switching (MPLS) Layer 3 virtual private networks (L3VPNs).

This extension is backward compatible and is defined in RFC 4670 including the following features:

  • Address Family Identifier (AFI)
  • Optional and non-transitive attributes: Multiprotocol reachable NLRI and Multiprotocol unreachable NLRI

Optional and non-transitive attribute means that an unrecognizing BGP speaker can ignore it and not advertise to its BGP neighbor.

Multiprotocol reachable NLRI carries the information about the reachable destinations and the next-hop address used to forward packets to these destinations. Multiprotocol unreachable NLRI, on the other hand, is used for withdrawing routes or removing them from advertisements.

MP-BGP extensions add an AFI that identifies the network layer protocol it supports, combined with the Subsequent Address Family Identifier (SAFI) which defines whether the prefixes apply to the same unicast prefixes and multicast routes or to unicast and multicast routes or routing tables.

mp bgp

MP-BGP Configuration

Router1(config)#ipv6 unicast-routing
Router1(config)#interface loopback 0
Router1(config-if)#ipv6 enable
Router1(config-if)#ipv6 address 2001:DB8::1/128
Router1(config)#interface GigabitEthernet0/0
Router1(config-if)#ipv6 enable
Router1(config-if)#ipv6 address 2001:DB8:0:10::1/64
Router1(config)#router bgp 1
Router1(config-router)#bgp log-neighbor-changes
Router1(config-router)#neighbor 2001:db8:0:10::2 remote-as 65200
Router1(config-router)#address-family ipv4
Router1(config-router-af)#no neighbor 2001:db8:0:10::2 activate
Router1(config-router-af)#exit-address-family
Router1(config-router)#address-family ipv6
Router1(config-router-af)#neighbor 2001:db8:0:10::2 activate
Router1(config-router-af)#network 2001:db8::1/128
Router1(config-router-af)#exit-address-family

 

Router2(config)#ipv6 unicast-routing
Router2(config)#interface loopback 0
Router2(config-if)#ipv6 enable
Router2(config-if)#ipv6 address 2001:DB8::2/128
Router2(config)#interface GigabitEthernet0/0
Router2(config-if)#ipv6 enable
Router2(config-if)#ipv6 address 2001:DB8:0:10::2/64
Router2(config)#router bgp 2
Router2(config-router)#bgp log-neighbor-changes
Router2(config-router)#neighbor 2001:db8:0:10::1 remote-as 65100
Router2(config-router)#address-family ipv4
Router2(config-router-af)#no neighbor 2001:db8:0:10::1 activate
Router2(config-router-af)#exit-address-family
Router2(config-router)#address-family ipv6
Router2(config-router-af)#neighbor 2001:db8:0:10::1 activate
Router2(config-router-af)#network 2001:db8::2/128
Router2(config-router-af)#exit-address-family

 

Verification

Router1#show ipv6 route bgp
IPv6 Routing Table - default - 7 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
D - EIGRP, EX - EIGRP external, NM - NEMO, ND - Neighbor Discovery
l - LISP
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B 2001:DB8::2/128 [20/0]
via FE80::217:5AFF:FEED:7AF0, GigabitEthernet0/0

 

Router1#show ipv6 route bgp
IPv6 Routing Table - default - 7 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
D - EIGRP, EX - EIGRP external, NM - NEMO, ND - Neighbor Discovery
l - LISP
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B 2001:DB8::1/128 [20/0]
via FE80::217:5AFF:FEED:7AF0, GigabitEthernet0/0

Download our Free CCNA Study Guide PDF for complete notes on all the CCNA 200-301 exam topics in one book.

We recommend the Cisco CCNA Gold Bootcamp as your main CCNA training course. It’s the highest rated Cisco course online with an average rating of 4.8 from over 30,000 public reviews and is the gold standard in CCNA training: