BGP Route Summarization Explained and Configured

BGP route summarization is best used, especially nowadays where most service providers do not accept prefixes larger than /24 for IPv4 (/25 through /32), The use of route summarization helps reduce the size of routing tables and conserves network resources. It also improves network efficiency by reducing the amount of processing power needed to handle routing updates. Implementing route summarization involves multiple BGP route aggregation into a single, summarized route, which can be advertised to other routers in the network. This simplifies routing decisions and improves overall network performance.

BGP Route Summarization Hiding Link Flaps

There are two techniques for Configuring BGP route summarization:

  • Static: Create a static route to Null0 for the summary network prefix and then advertise the prefix with a network statement. The downfall of this technique is that the summary route is always advertised, even if the networks are not available.
  • Dynamic: Configure an aggregation network prefix. When viable component aggregated route that match the aggregate network prefix enter the BGP table, then the aggregate prefix is created. The originating router sets the next hop to Null0 as a discard route for the aggregated prefix for routing loops prevention.

Aggregate Address

Route aggregation in BGP helps reduce the size of the routing table by combining multiple routes into a single summarized route. Dynamic route summarization is accomplished with the BGP route aggregation with this aggregate address command: aggregate-address network subnet-mask [summary-only] [as-set].

In both methods of BGP route aggregation, a new network prefix with a shorter prefix length is advertised in BGP. Because the aggregated route prefix is a new route, the summarizing router is the originator for the new aggregate route.

 

bgp route summarization

Router1 Configuration

R1(config)#router bgp 1
R1(config-router)#network 1.1.1.0 mask 255.255.255.0
R1(config-router)#no synchronization
Router1(config-router)#bgp log-neighbor-changes
Router1(config-router)#network 1.1.1.0
Router1(config-router)#neighbor 192.168.10.2 remote-as 2
Router1(config-router)#neighbor 192.168.10.2 remote-as 2
Router1(config-router)#aggregate-address 172.16.0.0 255.255.0.0
Router1(config)#interface loopback 0
Router1(config-if)#ip address 172.168.0.1 255.255.255.0
Router1(config-router)#network 172.168.0.0 mask 255.255.255.0
Router1(config-router)#exit
Router1(config)#ip route 172.168.0.0 255.255.0.0 null 0
Router1(config-router)#no auto-summary

 

Router2 Configuration

Router2(config)#router bgp 2
Router2(config-router)#no synchronization
Router2(config-router)#bgp log-neighbor-changes
Router2(config-router)#neighbor 192.168.10.1 remote-as 1
Router2(config-router)#no auto-summary

 

BGP Summarization

Router1#show run | section router bgp
router bgp 1
no synchronization
bgp log-neighbor-changes
aggregate-address 172.168.0.0 255.255.0.0
neighbor 192.168.10.2 remote-as 2
no auto-summary

 

Router2#show run | section router bgp
router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 192.168.10.1 remote-as 1
no auto-summary

 

Router2#show ip bgp summary | begin Neighbor
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.168.10.1 4 1 21 19 3 0 0 00:16:21 0

 

Router2#show ip route bgp
B 172.168.0.0/16 [20/0] via 192.168.10.1, 00:00:45

 

BGP Auto-Summary

Router1#show ip bgp 1.0.0.0
BGP routing table entry for 1.0.0.0/8, version 3
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Advertised to update-groups:
1
Local
0.0.0.0 from 0.0.0.0 (1.1.1.1)
Origin incomplete, metric 0, localpref 100, weight 32768, valid, sourced, best

 

Router1#show ip route 1.0.0.0
Routing entry for 1.0.0.0/24, 1 known subnets
Attached (1 connections)
Redistributing via bgp 1
Advertised by bgp 1
C 1.1.1.0 is directly connected, Loopback0

 

Router1#show ip protocols
Routing Protocol is "bgp 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
IGP synchronization is disabled
Automatic route summarization is enabled

 

Router2#show ip route bgp
1.0.0.0/24 is subnetted, 1 subnets
B 1.1.1.0 [20/0] via 192.168.18.1, 00:00:20

Download our Free CCNA Study Guide PDF for complete notes on all the CCNA 200-301 exam topics in one book.

We recommend the Cisco CCNA Gold Bootcamp as your main CCNA training course. It’s the highest rated Cisco course online with an average rating of 4.8 from over 30,000 public reviews and is the gold standard in CCNA training: