IPv6 OSPF Version 3 (OSPFv3) Configuration & Verification

To configure IPv6 OSPF version 3 (OSPFv3) routing protocol, IPv6 addressing and unicast-routing must be already configured on the network devices. For our example configuration, we have two routers, R1 and R2, and we’ll configure OSPFv3 routing between them.

ipv6 ospf

IPv6 OSPFv3 Configuration

Again, first thing, we have to configure unicast-routing on R1 and R2 so that routing protocols will work for IPv6.

R1(config)#ipv6 unicast-routing
R2(config)#ipv6 unicast-routing

Next, we’ll set the IPv6 loopback addresses.

R1(config)#interface loopback 0
R1(config-if)#ipv6 address 2001::1/128
R2(config)#interface loopback 0
R2(config-if)#ipv6 address 2001::2/128

 

Then, we have to enable IPv6 on our interfaces and configure their IPv6 addresses as well.

R1(config)#interface G0/0/0
R1(config-if)#ipv6 enable
R1(config-if)#ipv6 address 2001:db8:0:20::1/64
R1(config)#int G0/0/1
R1(config-if)#ipv6 enable
R1(config-if)#ipv6 address 2001:db8:0:10::1/64

 

R2(config)#interface G0/0/0
R2(config-if)#ipv6 enable
R2(config-if)#ipv6 address 2001:db8:0:20::2/64
R2(config)#interface G0/0/1
R2(config-if)#ipv6 enable
R2(config-if)#ipv6 address 2001:db8:0:30::1/64

 

So that’s our basic configuration done. Now let’s enable OSPFv3 on our routers using the ‘ipv6 router ospfv3 <process-id>’ command at the global configuration mode. We also have to assign a router ID for the OSPF routing process if there are no IPv4 addresses configured on the router. The command to do this is ‘router-id <router-id>’, and it is entered under the OSPF router configuration mode. The router ID resembles an IPv4 address and it can have any value as long as it is unique within the OSPF domain.

R1(config)#ipv6 router ospf 1
R1(config-rtr)#router-id 1.1.1.1
R1(config-rtr)#exit

 

R2(config)#ipv6 router ospf 1
R2(config-rtr)#router-id 2.2.2.2
R2(config-rtr)#exit

 

Finally, we have to assign our interfaces to their corresponding OSPFv3 areas. Under the interface configuration mode, enter the command ‘ipv6 ospf <process id> area <area number>’. For our example, we will assign all interfaces into area 0.

R1(config)#interface range G0/0/0-1
R1(config-if)#ipv6 ospf 1 area 0
R1(config)#interface loopback 0
R1(config-if)#ipv6 ospf 1 area 0

 

R2(config)#interface range G0/0/0-1
R2(config-if)#ipv6 ospf 1 area 0
R2(config)#interface loopback 0
R2(config-if)#ipv6 ospf 1 area 0

 

IPv6 OSPFv3 Verification

To check the IPv6 addresses on the router, we can use the ‘show ipv6 interface brief’ command.

R1#show ipv6 interface brief
GigabitEthernet0/0/0 [up/up]
FE80::5054:FF:FE0F:F10A
2001:DB8:0:20::1
GigabitEthernet0/0/1 [up/up]
FE80::5054:FF:FE0B:CEFB
2001:DB8:0:10::1
GigabitEthernet0/0/2 [administratively down/down]
unassigned
GigabitEthernet0/0/3 [administratively down/down]
unassigned
Loopback0 [up/up]
FE80::5054:FF:FE0F:F10A
2001::1

 

To view the OSPFv3 neighbor, we can use the command ‘show ipv6 ospf neighbor‘.

R1#show ipv6 ospf neighbor
OSPFv3 Router with ID (1.1.1.1) (Process ID 1)
Neighbor ID Pri State Dead Time Interface ID Interface
2.2.2.2 1 FULL/DR 00:00:38 2 GigabitEthernet0/0

 

R2#show ipv6 ospf neighbor
OSPFv3 Router with ID (2.2.2.2) (Process ID 1)
Neighbor ID Pri State Dead Time Interface ID Interface
1.1.1.1 1 FULL/BDR 00:00:38 2 GigabitEthernet0/0

 

We can also have a detailed view of the OSPFv3 interface configurations using the ‘show ospfv3 interface’ command.

R1#show ospfv3 interface
Loopback0 is up, line protocol is up
Link Local Address FE80::5054:FF:FE0F:F10A, Interface ID 9
Area 0, Process ID 1, Instance ID 0, Router ID 1.1.1.1
Network Type LOOPBACK, Cost: 1
Loopback interface is treated as a stub Host
GigabitEthernet0/1 is up, line protocol is up
Link Local Address FE80::5054:FF:FE0B:CEFB, Interface ID 3
Area 0, Process ID 1, Instance ID 0, Router ID 1.1.1.1
Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 1.1.1.1, local address FE80::5054:FF:FE0B:CEFB
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:00
Graceful restart helper support enabled
Index 1/2/2, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
GigabitEthernet0/0 is up, line protocol is up
Link Local Address FE80::5054:FF:FE0F:F10A, Interface ID 2
Area 0, Process ID 1, Instance ID 0, Router ID 1.1.1.1
Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 2.2.2.2, local address FE80::5054:FF:FE10:8031
Backup Designated router (ID) 1.1.1.1, local address FE80::5054:FF:FE0F:F10A
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:07
Graceful restart helper support enabled
Index 1/1/1, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 2
Last flood scan time is 0 msec, maximum is 1 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 2.2.2.2 (Designated Router)
Suppress hello for 0 neighbor(s)

 

The command ‘show ipv6 route ospf’ shows the OSPFv3 IPv6 routing table.

R1#show ipv6 route ospf
IPv6 Routing Table - default - 8 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
lA - LISP away, a - Application

O 2001::2/128 [110/1]
via FE80::5054:FF:FE10:8031, GigabitEthernet0/0
O 2001:DB8:0:30::/64 [110/2]
via FE80::5054:FF:FE10:8031, GigabitEthernet0/0

Download our Free CCNA Study Guide PDF for complete notes on all the CCNA 200-301 exam topics in one book.

We recommend the Cisco CCNA Gold Bootcamp as your main CCNA training course. It’s the highest rated Cisco course online with an average rating of 4.8 from over 30,000 public reviews and is the gold standard in CCNA training: