BGP Atomic Aggregate Explained and Configured

With shorter name prefixes and lengths, aggregated routes function similarly to recently formed BGP routes. When a BGP router summarizes routes, the summary route does not advertise the prior AS path information as set above. The new BGP advertisement excludes BGP path attributes such as AS Path, MED, and BGP communities. Path-lost information is indicated via the BGP atomic aggregate attribute. This functionality helps to prevent routing loops and black holes in the network. BGP routers can enhance network management and performance by merging routes and shrinking the size of the routing tables. As a result, routing decisions could be simpler and more effective.

 

BGP Attributes: Atomic Aggregate Attribute

The Atomic Aggregate attribute’s purpose is to notify BGP speakers along the aggregate of path that some information has been lost as a result of the BGP route aggregation process and that the new aggregate route path may not be the best path to the destination. This attribute is particularly useful in scenarios where route aggregation is necessary to reduce the size of the routing table.

It allows BGP speakers to understand that the aggregated route may not provide the most efficient path for traffic forwarding. By signaling this information, network administrators can make informed decisions about when and where to perform BGP route aggregation, balancing the trade-off between reducing routing table size and maintaining optimal network performance.

 

Route Aggregation Attributes

Router Aggregation Attributes is when an aggregator attribute aggregates some or more specific routes together, the route aggregator attaches its Router-ID to the aggregated route into the AGGREGATOR_ID attribute, and it sets the ATOMIC_AGGREGATE attribute or not based on whether the AS_PATH information of the aggregated routes was preserved or not. This information allows network administrators to efficiently manage their routing tables and ensure optimal network performance.

The Router-ID attached to the aggregated route in the AGGREGATOR_ID attribute helps identify the source of the route aggregation. Additionally, the ATOMIC_AGGREGATE attribute indicates whether the AS_PATH information of the aggregated routes was preserved, providing further insight into the routing process. Overall, these attributes aid in decision-making regarding route aggregation and balancing the trade-off between routing table size and network performance. They play a crucial role in optimizing network efficiency.

 

Configuration Example

 

as set bgp

Router1 Configuration

Router(config)#ip cef
Router(config)#interface gigabitEthernet0/0
Router(config-if)#ip address 192.168.10.1 255.255.255.0
Router(config)#interface gigabitEthernet0/1
Router(config-if)#ip address 192.168.20.1 255.255.255.0
Router(config)#interface gigabitEthernet0/2
Router(config-if)#ip address 192.168.30.1 255.255.255.0
Router(config)#router bgp 1
Router(config-router)#neighbor 192.168.10.2 remote-as 2
Router(config-router)#neighbor 192.168.20.2 remote-as 3
Router(config-router)#neighbor 192.168.30.2 remote-as 4

Router2 Configuration

Router(config)#ip cef
Router(config)#interface loopback0
Router(config-if)#ip address 172.168.10.10 255.255.255.255
Router(config)#interface gigabitEthernet0/0
Router(config-if)#ip address 192.168.10.2 255.255.255.0
Router(config)#router bgp 2
Router(config-router)#network 172.168.10.10 mask 255.255.255.255
Router(config-router)#neighbor 192.168.10.1 remote-as 1

Router3 Configuration

Router(config)#ip cef
Router(config)#interface loopback0
Router(config-if)#ip address 172.168.20.20 255.255.255.255
Router(config)#interface gigabitEthernet0/1
Router(config-if)#ip address 192.168.20.2 255.255.255.0
Router(config)#router bgp 3
Router(config-router)#network 172.168.20.20 mask 255.255.255.255
Router(config-router)#neighbor 192.168.20.1 remote-as 1

Router4 Configuration

Router(config)#ip cef
Router(config)#interface gigabitEthernet0/2
Router(config-if)#ip address 192.168.30.2 255.255.255.0
Router(config)#router bgp 4
Router(config-router)#neighbor 192.168.30.1 remote-as 1
Router4#show ip bgp
BGP table version is 3, local router ID is 192.168.30.2
Status codes: suppressed, d damped, h history, valid, > best, i - internal,
RIB-failure, Stale, multipath, b backup-path, f RT-Filter,
best-external, additional-path, RIB-compressed,
secondary path,
Network Next Hop Metric LocPrf Weight Path
*> 172.168.10.10/32 192.168.30.1 0 1 2 i
*> 172.168.20.20/32 192.168.30.1 0 1 3 i

 

Aggregate without AS-SET

Router1(config)#router bgp 1
Router1(config-router)#aggregate-address 192.168.0.0 255.255.0.0 summary-only

 

Router4#show ip bgp
BGP table version is 10, local router ID is 192.168.30.2
Status codes: suppressed, damped, history, valid, > best, i - internal,
RIB-failure, Stale, m multipath, backup-path, RT-Filter,
best-external, additional-path, RIB-compressed,
secondary path,
Network Next Hop Metric LocPrf Weight Path
*> 172.168.0.0 192.168.30.1 0 0 1 i

Download our Free CCNA Study Guide PDF for complete notes on all the CCNA 200-301 exam topics in one book.

We recommend the Cisco CCNA Gold Bootcamp as your main CCNA training course. It’s the highest rated Cisco course online with an average rating of 4.8 from over 30,000 public reviews and is the gold standard in CCNA training: